Inbound call Issues
Incident Report for Local Technology
Resolved
Our upstream carrier has resolved the issue with inbound calling.
Posted Jan 10, 2022 - 10:14 NZDT
Investigating
We are receiving reports of inbound call failures from certain phone carriers. Our upstream provider is investigating the cause of this incident.

Please email any support issues to support@localtechnology.co.nz
Posted Jan 10, 2022 - 09:36 NZDT