Some Emails are being routed to Junk Mail - M365 - EX258373
Incident Report for Local Technology
Resolved
This incident has been resolved.
Posted May 27, 2021 - 15:37 NZST
Monitoring
Microsoft has advised they have fixed the issue and they are continuing to monitor the remaining messages whilst they are being reprocessed.
Posted May 27, 2021 - 13:24 NZST
Update
Microsoft is continuing to work on the issue.
Posted May 27, 2021 - 12:56 NZST
Investigating
User Impact: Users may observe that incoming mail is being routed to their junk folder for those using Microsoft 365.

Microsoft is looking into the issue and is expected to provide us with an update by 10:30 am
Posted May 27, 2021 - 09:23 NZST
This incident affected: Microsoft Cloud Services.