2Degrees Mobile Outage
Incident Report for Local Technology
Resolved
This incident has been resolved.
Posted Nov 11, 2022 - 11:11 NZDT
Investigating
Some customers may be having trouble with their mobile services currently

For the latest updates please see the official 2Degrees Twitter account
https://twitter.com/2degreesmobile
Posted Nov 11, 2022 - 10:05 NZDT