Microsoft Teams Outage
Incident Report for Local Technology
Resolved
Microsoft is observing continued improvement for a majority of the functions within Microsoft Teams. They are focused on the areas that have not recovered and are taking action to restore service at the highest priority.
Posted Jul 21, 2022 - 16:36 NZST
Monitoring
Microsoft is receiving many reports that users are able to access Microsoft Teams, and many functions are beginning to recover. They are continuing to work to fully restore the service at their highest priority.
Posted Jul 21, 2022 - 16:07 NZST
Update
Microsoft is rerouting Microsoft Teams traffic to an alternate region in an effort to provide some relief and potentially restore some functionality to the service.
Posted Jul 21, 2022 - 15:28 NZST
Identified
Microsoft has determined that a recent deployment contained a broken connection to an internal storage service, which has resulted in the service becoming unstable. They are working to direct traffic to a healthy service to mitigate impact.

For more information see
https://twitter.com/MSFT365Status
Posted Jul 21, 2022 - 15:15 NZST
Investigating
Users may be unable to access Microsoft Teams Investigations are currently on-going.
Posted Jul 21, 2022 - 14:14 NZST
This incident affected: Microsoft Cloud Services.